How to install Comodo Antivirus for Linux on ubuntu

Comodo Antivirus for Linux (CAVL) is a free antivirus and mail gateway software for your linux system from Comodo Group, Inc. The mail gateway provides anti-spam filter and it block email related threats.And it compatible with Postfix, qmail, Sendmail and Exim MTA’s. It comes with automatic updates, scan scheduler, event viewer and custom scan profiles.

Install Comodo Antivirus for Linux on ubuntu:

Go to Comodo Antivirus for Linux download page. And choose your operating system as Ubuntu from the dropdown and also select 32-bit or 64-bit based on your system. And click the download button. By default, it will download the file in your Downloads folder. The downloaded file name is cav-linux_x64.deb (its for the 64-bit OS). For the 32-bit oS its cav-linux_x86.deb.

Download Comodo Antivirus for linux

To install Comodo Antivirus for Linux, you need to install libssl0.9.8. But in ubuntu 16.04 or later have newer than Comodo wants. But anyway you need to install this libssl0.9.8

Download libssl0.9.8 (for 64-bit)

Download libssl0.9.8 (for 32-bit)

Download libssl0.9.8 for your OS type (32 or 64 bit) from above link. The default download location is Downloads folder. Open your terminal app and run the below command.

cd Downloads

Then run the below command in terminal.

Suggested Read:  How to install Dungeon Crawl Stone Soup Game on Ubuntu

For 64 bit

sudo dpkg -i libssl0.9.8_0.9.8o-7ubuntu3.2_amd64.deb

OR
For 32 bit

sudo dpkg -i libssl0.9.8_0.9.8o-7ubuntu3.2_i386.deb

Then type the below command in your terminal and hit enter.

sudo apt-get install -f

Then run the below command one by on in your terminal.

sudo dpkg -i cav-linux_x64.deb
sudo apt-get install -f
sudo /opt/COMODO/post_setup.sh

Note: If you get any error regarding libssl on Ubuntu 20.04, then you can ignore those dependencies because Ubuntu 20.04 already have version 1.1.1. Thanks Dave M for this info.

Just replace “sudo dpkg -i cav-linux_x64.deb” this command with below command.

sudo dpkg โ€“ignore-depends=libssl0.9.8 -i cav-linux_x64.deb

then run all others one by one.

when asked press enter. Then continuously press enter to read and confirm the installation.

If you liked this article, please subscribe to our YouTube Channel. You can also stay connected with us on Twitter and Facebook.

You may also like...

10 Responses

  1. Dave M. says:

    This can be installed on Ubuntu 20.04 focal. LibSSL is already at version 1.1.1 on focal, so you can ignore those dependencies…

    dpkg –ignore-depends=libssl0.9.8 -i cav-linux_x64.deb

    This command got it to install for me. Good luck to all.

  2. AVT says:

    Comodo cannot be installed on Ubuntu 20.04 either. ๐Ÿ™

    I switched to Dr.Web Security Space for Linux.

  3. Name says:

    I tried typing in: sudo dpkg -i libssl0.9.8_0.9.8o-7ubuntu3.2_amd64.deb
    but it just says that it couldn’t find it. “file or directory is missing”.
    please help

    • Manikandan says:

      move the downloaded file “libssl0.9.8_0.9.8o-7ubuntu3.2_amd64.deb” to your “Downloads” folder then run one by one
      cd Downloads
      sudo dpkg -i libssl0.9.8_0.9.8o-7ubuntu3.2_amd64.deb
      sudo apt-get install -f

      it will work

  4. sanjee says:

    how i can sole this
    filesystem filter
    &
    comodo agent not running

  5. Marcello Bassani says:

    Excellent ‘Helping Hand’ (after my looking and working for hours for a solution for this PC ๐Ÿ™‚

  6. A webb says:

    The first time I installed Comodo Antivirus on Linux mint 19.1 just a few days ago, and trying to start in from the desktop icon and with in the all application menu , but it did not even start up. I uninstall it and later I try following the instruction using the terminal command line, then I keep getting at error.

Leave a Reply to Manikandan Cancel reply

Your email address will not be published. Required fields are marked *